PyPI/langchain-experimental CVE-2024-27444: critical 9.8, EPSS 0.77%
LangChain Experimental vulnerable to arbitrary code execution
Action: Upgrade langchain-experimental to 0.0.52 or later.
pip install langchain-experimental==0.0.52Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.0.52 | - |
Fixed versions
| 0.0.52 |
Sources
- osv: GHSA-v8vj-cv27-hjv8
- https://nvd.nist.gov/vuln/detail/CVE-2024-27444
- https://github.com/langchain-ai/langchain/commit/de9a6cdf163ed00adaf2e559203ed0a9ca2f1de7
- https://github.com/langchain-ai/langchain
- https://github.com/pypa/advisory-database/tree/main/vulns/langchain-experimental/PYSEC-2026-375.yaml
- https://pypi.org/project/langchain-experimental
CVE-2024-27444 · published · modified · JSON