PyPI/tensorflow-gpu CVE-2021-29581: low 2.5, EPSS 0.19%
Segfault in `CTCBeamSearchDecoder`
Action: Upgrade tensorflow-gpu to 2.1.4 or later.
pip install tensorflow-gpu==2.1.4pip install tensorflow-gpu==2.2.3pip install tensorflow-gpu==2.3.3pip install tensorflow-gpu==2.4.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.1.4 | - |
| 2.2.0 | 2.2.3 | - |
| 2.3.0 | 2.3.3 | - |
| 2.4.0 | 2.4.2 | - |
Fixed versions
| 2.1.4 | 2.2.3 | 2.3.3 | 2.4.2 |
Sources
- osv: GHSA-vq2r-5xvm-3hc3#PyPI/tensorflow-gpu
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-vq2r-5xvm-3hc3
- https://nvd.nist.gov/vuln/detail/CVE-2021-29581
- https://github.com/tensorflow/tensorflow/commit/b1b323042264740c398140da32e93fb9c2c9f33e
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-509.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-707.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-218.yaml
- https://github.com/tensorflow/tensorflow
CVE-2021-29581 · published · modified · JSON