PyPI/tensorflow-gpu CVE-2021-37667: high 7.8, EPSS 0.17%
Reference binding to nullptr in unicode encoding
Action: Upgrade tensorflow-gpu to 2.3.4 or later.
pip install tensorflow-gpu==2.3.4pip install tensorflow-gpu==2.4.3pip install tensorflow-gpu==2.5.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.3.4 | - |
| 2.4.0 | 2.4.3 | - |
| 2.5.0 | 2.5.1 | - |
Fixed versions
| 2.3.4 | 2.4.3 | 2.5.1 |
Sources
- osv: GHSA-w74j-v8xh-3w5h#PyPI/tensorflow-gpu
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-w74j-v8xh-3w5h
- https://nvd.nist.gov/vuln/detail/CVE-2021-37667
- https://github.com/tensorflow/tensorflow/commit/2e0ee46f1a47675152d3d865797a18358881d7a6
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-580.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-778.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-289.yaml
- https://github.com/tensorflow/tensorflow
CVE-2021-37667 · published · modified · JSON