PyPI/tensorflow-cpu CVE-2021-37648: high 7.8, EPSS 0.19%
Incorrect validation of `SaveV2` inputs
Action: Upgrade tensorflow-cpu to 2.3.4 or later.
pip install tensorflow-cpu==2.3.4pip install tensorflow-cpu==2.4.3pip install tensorflow-cpu==2.5.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.3.4 | - |
| 2.4.0 | 2.4.3 | - |
| 2.5.0 | 2.5.1 | - |
Fixed versions
| 2.3.4 | 2.4.3 | 2.5.1 |
Sources
- osv: GHSA-wp77-4gmm-7cq8#PyPI/tensorflow-cpu
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-wp77-4gmm-7cq8
- https://nvd.nist.gov/vuln/detail/CVE-2021-37648
- https://github.com/tensorflow/tensorflow/commit/9728c60e136912a12d99ca56e106b7cce7af5986
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-561.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-759.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-270.yaml
- https://github.com/tensorflow/tensorflow
CVE-2021-37648 · published · modified · JSON