PyPI/tensorflow-gpu CVE-2021-41202: medium 5.5, EPSS 0.21%
Overflow/crash in `tf.range`
Action: Upgrade tensorflow-gpu to 2.4.4 or later.
pip install tensorflow-gpu==2.6.1pip install tensorflow-gpu==2.5.2pip install tensorflow-gpu==2.4.4Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.6.0 | 2.6.1 | - |
| 2.5.0 | 2.5.2 | - |
| 0 | 2.4.4 | - |
Fixed versions
| 2.6.1 | 2.5.2 | 2.4.4 |
Sources
- osv: GHSA-xrqm-fpgr-6hhx#PyPI/tensorflow-gpu
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-xrqm-fpgr-6hhx
- https://nvd.nist.gov/vuln/detail/CVE-2021-41202
- https://github.com/tensorflow/tensorflow/issues/46889
- https://github.com/tensorflow/tensorflow/issues/46912
- https://github.com/tensorflow/tensorflow/commit/1b0e0ec27e7895b9985076eab32445026ae5ca94
- https://github.com/tensorflow/tensorflow/commit/6d94002a09711d297dbba90390d5482b76113899
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-612.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-810.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-395.yaml
- https://github.com/tensorflow/tensorflow
CVE-2021-41202 · published · modified · JSON