PyPI/setuptools CVE-2013-1633: unknown, EPSS 1.98%
easy_install in setuptools before 0.7 uses HTTP to retrieve packages from the PyPI repository, and does not perform integrity checks on package contents, which allows man-in-the-middle attackers to ex
Action: Upgrade setuptools to 0.7 or later.
pip install setuptools==0.7Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.7 | - |
Fixed versions
| 0.7 |
Sources
- osv: PYSEC-2013-22
- http://www.reddit.com/r/Python/comments/17rfh7/warning_dont_use_pip_in_an_untrusted_network_a/
- https://pypi.python.org/pypi/setuptools/0.9.8#changes
- https://github.com/advisories/GHSA-27x4-j476-jp5f
CVE-2013-1633 · published · modified · JSON