PyPI/pillow CVE-2014-3589: unknown, EPSS 3.36%
PIL/IcnsImagePlugin.py in Python Imaging Library (PIL) and Pillow before 2.3.2 and 2.5.x before 2.5.2 allows remote attackers to cause a denial of service via a crafted block size.
Action: Upgrade pillow to 2.3.2 or later.
pip install pillow==2.3.2pip install pillow==2.5.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.3.2 | - |
| 2.5 | 2.5.2 | - |
Fixed versions
| 2.3.2 | 2.5.2 |
Sources
- osv: PYSEC-2014-10
- https://pypi.python.org/pypi/Pillow/2.5.2
- https://pypi.python.org/pypi/Pillow/2.3.2
- http://www.debian.org/security/2014/dsa-3009
- https://github.com/python-pillow/Pillow/commit/205e056f8f9b06ed7b925cf8aa0874bc4aaf8a7d
- http://lists.opensuse.org/opensuse-updates/2015-04/msg00056.html
- http://secunia.com/advisories/59825
- https://github.com/advisories/GHSA-cfmr-38g9-f2h7
CVE-2014-3589 · published · modified · JSON