PyPI/pip CVE-2014-8991: unknown, EPSS 0.39%
pip 1.3 through 1.5.6 allows local users to cause a denial of service (prevention of package installation) by creating a /tmp/pip-build-* file for another user.
Action: Upgrade pip to 6.0 or later.
pip install pip==6.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 1.3 | 6.0 | - |
Fixed versions
| 6.0 |
Sources
- osv: PYSEC-2014-11
- https://github.com/pypa/pip/pull/2122
- http://www.securityfocus.com/bid/71209
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=725847
- http://www.openwall.com/lists/oss-security/2014/11/19/17
- http://www.openwall.com/lists/oss-security/2014/11/20/6
- http://www.oracle.com/technetwork/topics/security/bulletinjul2015-2511963.html
- https://github.com/advisories/GHSA-53mr-44pp-crf4
CVE-2014-8991 · published · modified · JSON