PyPI/django CVE-2014-1418: unknown, EPSS 2.57%
Django 1.4 before 1.4.13, 1.5 before 1.5.8, 1.6 before 1.6.5, and 1.7 before 1.7b4 does not properly include the (1) Vary: Cookie or (2) Cache-Control header in responses, which allows remote attacker
Action: Upgrade django to 1.4.13 or later.
pip install django==1.4.13pip install django==1.5.8pip install django==1.6.5pip install django==1.7b4Affected
| introduced | fixed | last affected |
|---|---|---|
| 1.4 | 1.4.13 | - |
| 1.5 | 1.5.8 | - |
| 1.6 | 1.6.5 | - |
| 1.7a0 | 1.7b4 | - |
Fixed versions
| 1.4.13 | 1.5.8 | 1.6.5 | 1.7b4 |
Sources
- osv: PYSEC-2014-19
- http://www.openwall.com/lists/oss-security/2014/05/15/3
- http://ubuntu.com/usn/usn-2212-1
- https://www.djangoproject.com/weblog/2014/may/14/security-releases-issued/
- http://www.openwall.com/lists/oss-security/2014/05/14/10
- http://www.debian.org/security/2014/dsa-2934
- http://lists.opensuse.org/opensuse-updates/2014-09/msg00023.html
- http://secunia.com/advisories/61281
- https://github.com/advisories/GHSA-q7q2-qf2q-rw3w
CVE-2014-1418 · published · modified · JSON