PyPI/django CVE-2014-3730: unknown, EPSS 3.15%
The django.util.http.is_safe_url function in Django 1.4 before 1.4.13, 1.5 before 1.5.8, 1.6 before 1.6.5, and 1.7 before 1.7b4 does not properly validate URLs, which allows remote attackers to conduc
Action: Upgrade django to 1.4.13 or later.
pip install django==1.4.13pip install django==1.5.8pip install django==1.6.5pip install django==1.7b4Affected
| introduced | fixed | last affected |
|---|---|---|
| 1.4 | 1.4.13 | - |
| 1.5 | 1.5.8 | - |
| 1.6 | 1.6.5 | - |
| 1.7a0 | 1.7b4 | - |
Fixed versions
| 1.4.13 | 1.5.8 | 1.6.5 | 1.7b4 |
Sources
- osv: PYSEC-2014-20
- http://ubuntu.com/usn/usn-2212-1
- https://www.djangoproject.com/weblog/2014/may/14/security-releases-issued/
- http://www.openwall.com/lists/oss-security/2014/05/15/3
- http://www.openwall.com/lists/oss-security/2014/05/14/10
- http://www.debian.org/security/2014/dsa-2934
- http://lists.opensuse.org/opensuse-updates/2014-09/msg00023.html
- http://www.securityfocus.com/bid/67410
- http://secunia.com/advisories/61281
- https://github.com/advisories/GHSA-vq3h-3q7v-9prw
CVE-2014-3730 · published · modified · JSON