PyPI/bottle CVE-2014-3137: unknown, EPSS 3.13%
Bottle 0.10.x before 0.10.12, 0.11.x before 0.11.7, and 0.12.x before 0.12.6 does not properly limit content types, which allows remote attackers to bypass intended access restrictions via an accepted
Action: Upgrade bottle to 0.10.12 or later.
pip install bottle==0.10.12pip install bottle==0.11.7pip install bottle==0.12.6Affected
| introduced | fixed | last affected |
|---|---|---|
| 0.8 | 0.10.12 | - |
| 0.11 | 0.11.7 | - |
| 0.12 | 0.12.6 | - |
Fixed versions
| 0.10.12 | 0.11.7 | 0.12.6 |
Sources
- osv: PYSEC-2014-77
- https://github.com/defnull/bottle/issues/616
- https://bugzilla.redhat.com/show_bug.cgi?id=1093255
- http://www.openwall.com/lists/oss-security/2014/05/01/15
- http://www.debian.org/security/2014/dsa-2948
- https://github.com/advisories/GHSA-873q-wpqr-xfgw
CVE-2014-3137 · published · modified · JSON