PyPI/logilab-common CVE-2014-1838: unknown, EPSS 0.34%
The (1) extract_keys_from_pdf and (2) fill_pdf functions in pdf_ext.py in logilab-commons before 0.61.0 allows local users to overwrite arbitrary files and possibly have other unspecified impact via a
Action: Upgrade logilab-common to 0.60.1 or later.
pip install logilab-common==0.60.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.60.1 | - |
Fixed versions
| 0.60.1 |
Sources
- osv: PYSEC-2014-83
- http://comments.gmane.org/gmane.comp.security.oss.general/11986
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=737051
- http://secunia.com/advisories/57209
- http://www.logilab.org/ticket/207561
- http://lists.opensuse.org/opensuse-updates/2014-02/msg00085.html
- https://github.com/advisories/GHSA-rr52-wg7f-8875
CVE-2014-1838 · published · modified · JSON