PyPI/lxml CVE-2014-3146: unknown, EPSS 6.33%
Incomplete blacklist vulnerability in the lxml.html.clean module in lxml before 3.3.5 allows remote attackers to conduct cross-site scripting (XSS) attacks via control characters in the link scheme to
Action: Upgrade lxml to 3.3.5 or later.
pip install lxml==3.3.5Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.3.5 | - |
Fixed versions
| 3.3.5 |
Sources
- osv: PYSEC-2014-9
- http://lxml.de/3.3/changes-3.3.5.html
- http://seclists.org/fulldisclosure/2014/Apr/210
- http://www.securityfocus.com/bid/67159
- http://www.openwall.com/lists/oss-security/2014/05/09/7
- http://secunia.com/advisories/58013
- http://seclists.org/fulldisclosure/2014/Apr/319
- https://mailman-mail5.webfaction.com/pipermail/lxml/2014-April/007128.html
- http://www.ubuntu.com/usn/USN-2217-1
- http://lists.opensuse.org/opensuse-updates/2014-05/msg00083.html
- http://secunia.com/advisories/58744
- http://secunia.com/advisories/59008
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:112
- http://advisories.mageia.org/MGASA-2014-0218.html
- http://www.debian.org/security/2014/dsa-2941
- https://github.com/advisories/GHSA-57qw-cc2g-pv5p
CVE-2014-3146 · published · modified · JSON