PyPI/python-gnupg CVE-2014-1927: unknown, EPSS 3.42%
The shell_quote function in python-gnupg 0.3.5 does not properly quote strings, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as d
Action: Upgrade python-gnupg to 0.3.6 or later.
pip install python-gnupg==0.3.6Affected
| introduced | fixed | last affected |
|---|---|---|
| 0.3.5 | 0.3.6 | - |
Fixed versions
| 0.3.6 |
Sources
- osv: PYSEC-2014-90
- https://code.google.com/p/python-gnupg/issues/detail?id=98
- http://seclists.org/oss-sec/2014/q1/294
- https://code.google.com/p/python-gnupg/
- http://secunia.com/advisories/59031
- http://secunia.com/advisories/56616
- http://seclists.org/oss-sec/2014/q1/245
- http://www.debian.org/security/2014/dsa-2946
- https://github.com/advisories/GHSA-r3vr-prwv-86g9
CVE-2014-1927 · published · modified · JSON