PyPI/django CVE-2015-5144: unknown, EPSS 3.17%
Django before 1.4.21, 1.5.x through 1.6.x, 1.7.x before 1.7.9, and 1.8.x before 1.8.3 uses an incorrect regular expression, which allows remote attackers to inject arbitrary headers and conduct HTTP r
Action: Upgrade django to 1.4.21 or later.
pip install django==1.4.21pip install django==1.7.9pip install django==1.8.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.4.21 | - |
| 1.5 | 1.7.9 | - |
| 1.8 | 1.8.3 | - |
Fixed versions
| 1.4.21 | 1.7.9 | 1.8.3 |
Sources
- osv: PYSEC-2015-10
- http://www.ubuntu.com/usn/USN-2671-1
- http://www.debian.org/security/2015/dsa-3305
- https://www.djangoproject.com/weblog/2015/jul/08/security-releases/
- http://www.oracle.com/technetwork/topics/security/bulletinoct2015-2511968.html
- http://www.securityfocus.com/bid/75665
- https://security.gentoo.org/glsa/201510-06
- http://lists.fedoraproject.org/pipermail/package-announce/2015-November/172084.html
- http://lists.opensuse.org/opensuse-updates/2015-10/msg00046.html
- http://lists.opensuse.org/opensuse-updates/2015-10/msg00043.html
- http://www.securitytracker.com/id/1032820
- https://github.com/advisories/GHSA-q5qw-4364-5hhm
CVE-2015-5144 · published · modified · JSON