tocsin

PyPI/dulwich CVE-2015-0838: unknown, EPSS 3.38%

Buffer overflow in the C implementation of the apply_delta function in _pack.c in Dulwich before 0.9.9 allows remote attackers to execute arbitrary code via a crafted pack file.

Action: Upgrade dulwich to 0.9.9 or later.

pip install dulwich==0.9.9

Affected

introducedfixedlast affected
00.9.9-

Fixed versions

0.9.9

Sources

CVE-2015-0838 · published · modified · JSON