PyPI/django CVE-2015-0220: unknown, EPSS 3.05%
The django.util.http.is_safe_url function in Django before 1.4.18, 1.6.x before 1.6.10, and 1.7.x before 1.7.3 does not properly handle leading whitespaces, which allows remote attackers to conduct cr
Action: Upgrade django to 1.4.18 or later.
pip install django==1.4.18pip install django==1.6.10pip install django==1.7.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.4.18 | - |
| 1.5 | 1.6.10 | - |
| 1.7 | 1.7.3 | - |
Fixed versions
| 1.4.18 | 1.6.10 | 1.7.3 |
Sources
- osv: PYSEC-2015-5
- http://secunia.com/advisories/62285
- https://www.djangoproject.com/weblog/2015/jan/13/security/
- http://secunia.com/advisories/62309
- http://ubuntu.com/usn/usn-2469-1
- http://secunia.com/advisories/62718
- http://advisories.mageia.org/MGASA-2015-0026.html
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:036
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:109
- http://lists.opensuse.org/opensuse-updates/2015-04/msg00001.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-January/148485.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-January/148608.html
- http://lists.opensuse.org/opensuse-updates/2015-09/msg00035.html
- https://github.com/advisories/GHSA-gv98-g628-m9x5
CVE-2015-0220 · published · modified · JSON