PyPI/django CVE-2015-2317: unknown, EPSS 4.97%
The utils.http.is_safe_url function in Django before 1.4.20, 1.5.x, 1.6.x before 1.6.11, 1.7.x before 1.7.7, and 1.8.x before 1.8c1 does not properly validate URLs, which allows remote attackers to co
Action: Upgrade django to 1.4.20 or later.
pip install django==1.4.20pip install django==1.6.11pip install django==1.7.7pip install django==1.8c1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.4.20 | - |
| 1.5 | 1.6.11 | - |
| 1.7 | 1.7.7 | - |
| 1.8a0 | 1.8c1 | - |
Fixed versions
| 1.4.20 | 1.6.11 | 1.7.7 | 1.8c1 |
Sources
- osv: PYSEC-2015-9
- http://ubuntu.com/usn/usn-2539-1
- https://www.djangoproject.com/weblog/2015/mar/18/security-releases/
- http://www.debian.org/security/2015/dsa-3204
- http://lists.opensuse.org/opensuse-updates/2015-04/msg00001.html
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:195
- http://lists.fedoraproject.org/pipermail/package-announce/2015-April/155421.html
- http://www.oracle.com/technetwork/topics/security/bulletinapr2015-2511959.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-June/160263.html
- http://www.securityfocus.com/bid/73319
- http://lists.opensuse.org/opensuse-updates/2015-09/msg00035.html
- https://github.com/advisories/GHSA-7fq8-4pv5-5w5c
CVE-2015-2317 · published · modified · JSON