PyPI/keystonemiddleware CVE-2015-7546: unknown, EPSS 2.00%
The identity service in OpenStack Identity (Keystone) before 2015.1.3 (Kilo) and 8.0.x before 8.0.2 (Liberty) and keystonemiddleware (formerly python-keystoneclient) before 1.5.4 (Kilo) and Liberty be
Action: Upgrade keystonemiddleware to 1.5.4 or later.
pip install keystonemiddleware==1.5.4pip install keystonemiddleware==2.3.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.5.4 | - |
| 1.6.0 | 2.3.3 | - |
Fixed versions
| 1.5.4 | 2.3.3 |
Sources
- osv: PYSEC-2016-20
- https://bugs.launchpad.net/keystone/+bug/1490804
- https://wiki.openstack.org/wiki/OSSN/OSSN-0062
- https://security.openstack.org/ossa/OSSA-2016-005.html
- http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html
- http://www.securityfocus.com/bid/80498
- https://github.com/advisories/GHSA-8c4w-v65p-jvcv
CVE-2015-7546 · published · modified · JSON