tocsin

PyPI/mercurial CVE-2016-3630: unknown, EPSS 4.87%

The binary delta decoder in Mercurial before 3.7.3 allows remote attackers to execute arbitrary code via a (1) clone, (2) push, or (3) pull command, related to (a) a list sizing rounding error and (b)

Action: Upgrade mercurial to 3.7.3 or later.

pip install mercurial==3.7.3

Affected

introducedfixedlast affected
03.7.3-

Fixed versions

3.7.3

Sources

CVE-2016-3630 · published · modified · JSON