PyPI/pyanyapi CVE-2017-16616: critical 9.8, EPSS 3.62%
An exploitable vulnerability exists in the YAML parsing functionality in the YAMLParser method in Interfaces.py in PyAnyAPI before 0.6.1. A YAML parser can execute arbitrary Python commands resulting
Action: Upgrade pyanyapi to 0.6.1 or later.
pip install pyanyapi==0.6.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.6.1 | - |
Fixed versions
| 0.6.1 |
Sources
- osv: PYSEC-2017-23
- nvd: CVE-2017-16616
- https://pypi.python.org/pypi/pyanyapi/0.6.1
- https://github.com/Stranger6667/pyanyapi/releases/tag/0.6.1
- https://github.com/Stranger6667/pyanyapi/issues/41
- https://joel-malwarebenchmark.github.io/blog/2017/11/08/cve-2017-16616-yamlparser-in-pyanyapi/
- https://github.com/advisories/GHSA-vg8g-jpm9-jh8r
CVE-2017-16616 · published · modified · JSON