PyPI/openpyxl CVE-2017-5992: high 8.2, EPSS 1.41%
Openpyxl 2.4.1 resolves external entities by default, which allows remote attackers to conduct XXE attacks via a crafted .xlsx document.
Action: Upgrade openpyxl to 2.4.1 or later.
pip install openpyxl==2.4.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.4.1 | - |
Fixed versions
| 2.4.1 |
Sources
- osv: PYSEC-2017-48
- nvd: CVE-2017-5992
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=854442
- https://bitbucket.org/openpyxl/openpyxl/issues/749
- https://bitbucket.org/openpyxl/openpyxl/commits/3b4905f428e1
- http://www.openwall.com/lists/oss-security/2017/02/07/5
- https://github.com/advisories/GHSA-chqf-hx79-gxc6
CVE-2017-5992 · published · modified · JSON