PyPI/cfscrape CVE-2017-7235: unknown, EPSS 1.55%
An issue was discovered in cloudflare-scrape 1.6.6 through 1.7.1. A malicious website owner could craft a page that executes arbitrary Python code against any cfscrape user who scrapes that website. T
Action: Upgrade cfscrape to 1.8.0 or later.
pip install cfscrape==1.8.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 1.6.6 | 1.8.0 | - |
Fixed versions
| 1.8.0 |
Sources
- osv: PYSEC-2017-7
- https://github.com/Anorov/cloudflare-scrape/releases/tag/1.8.0
- https://github.com/Anorov/cloudflare-scrape/issues/97
- http://www.securityfocus.com/bid/97191
- https://github.com/advisories/GHSA-5mc5-5j6c-qmf9
CVE-2017-7235 · published · modified · JSON