tocsin

PyPI/mercurial CVE-2017-17458: unknown, EPSS 6.33%

In Mercurial before 4.4.1, it is possible that a specially malformed repository can cause Git subrepositories to run arbitrary code in the form of a .git/hooks/post-update script checked into the repo

Action: Upgrade mercurial to 4.4.1 or later.

pip install mercurial==4.4.1

Affected

introducedfixedlast affected
04.4.1-

Fixed versions

4.4.1

Sources

CVE-2017-17458 · published · modified · JSON