PyPI/tlslite-ng CVE-2018-1000159: unknown, EPSS 0.77%
tlslite-ng version 0.7.3 and earlier, since commit d7b288316bca7bcdd082e6ccff5491e241305233 contains a CWE-354: Improper Validation of Integrity Check Value vulnerability in TLS implementation, tlslit
Action: Upgrade tlslite-ng to 0.7.4 or later.
pip install tlslite-ng==0.7.4Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.7.4 | - |
Fixed versions
| 0.7.4 |
Sources
- osv: PYSEC-2018-31
- https://github.com/tomato42/tlslite-ng/pull/234
- https://github.com/advisories/GHSA-cwh5-3cw7-4286
CVE-2018-1000159 · published · modified · JSON