PyPI/ansible CVE-2018-10875: unknown, EPSS 0.59%
A flaw was found in ansible. ansible.cfg is read from the current working directory which can be altered to make it point to a plugin or a module path under the control of an attacker, thus allowing t
Action: Upgrade ansible to 2.4.6.0 or later.
pip install ansible==2.5.6pip install ansible==2.4.6.0pip install ansible==2.6.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.4 | 2.4.6.0 | - |
| 2.5 | 2.5.6 | - |
| 2.6 | 2.6.1 | - |
Fixed versions
| 2.5.6 | 2.4.6.0 | 2.6.1 |
Sources
- osv: PYSEC-2018-43
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10875
- https://access.redhat.com/errata/RHSA-2018:2166
- https://access.redhat.com/errata/RHSA-2018:2152
- https://access.redhat.com/errata/RHSA-2018:2151
- https://access.redhat.com/errata/RHSA-2018:2150
- https://access.redhat.com/errata/RHSA-2018:2321
- http://www.securitytracker.com/id/1041396
- https://access.redhat.com/errata/RHSA-2018:2585
- https://access.redhat.com/errata/RHBA-2018:3788
- https://access.redhat.com/errata/RHSA-2019:0054
- https://www.debian.org/security/2019/dsa-4396
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00021.html
- https://usn.ubuntu.com/4072-1/
- https://lists.debian.org/debian-lts-announce/2019/09/msg00016.html
- https://github.com/advisories/GHSA-fc4h-467w-46rh
CVE-2018-10875 · published · modified · JSON