tocsin

PyPI/websockets CVE-2018-1000518: unknown, EPSS 1.80%

aaugustin websockets version 4 contains a CWE-409: Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Servers and clients, unless configured with compression=None that c

Action: Upgrade websockets to 5.0 or later.

pip install websockets==5.0

Affected

introducedfixedlast affected
05.0-

Fixed versions

5.0

Sources

CVE-2018-1000518 · published · modified · JSON