tocsin

PyPI/waitress CVE-2019-16789: unknown, EPSS 2.59%

In Waitress through version 1.4.0, if a proxy server is used in front of waitress, an invalid request may be sent by an attacker that bypasses the front-end and is parsed differently by waitress leadi

Action: Upgrade waitress to 1.4.1 or later.

pip install waitress==1.4.1

Affected

introducedfixedlast affected
01.4.1-

Fixed versions

1.4.1

Sources

CVE-2019-16789 · published · modified · JSON