PyPI/ansible CVE-2019-10206: unknown, EPSS 1.52%
ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passwords by expanding them from templates as they could contain
Action: Upgrade ansible to 2.6.19 or later.
pip install ansible==2.6.19pip install ansible==2.7.13pip install ansible==2.8.4Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.6.0 | 2.6.19 | - |
| 2.7.0 | 2.7.13 | - |
| 2.8.0 | 2.8.4 | - |
Fixed versions
| 2.6.19 | 2.7.13 | 2.8.4 |
Sources
- osv: PYSEC-2019-145
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10206
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html
- https://github.com/advisories/GHSA-cqmr-rcpr-cxh3
CVE-2019-10206 · published · modified · JSON