PyPI/ansible CVE-2019-14858: unknown, EPSS 0.42%
A vulnerability was found in Ansible engine 2.x up to 2.8 and Ansible tower 3.x up to 3.5. When a module has an argument_spec with sub parameters marked as no_log, passing an invalid parameter name to
Action: Upgrade ansible to 2.8.1 or later.
pip install ansible==2.8.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.0 | 2.8.1 | - |
Fixed versions
| 2.8.1 |
Sources
- osv: PYSEC-2019-171
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14858
- https://access.redhat.com/errata/RHSA-2019:3207
- https://access.redhat.com/errata/RHSA-2019:3201
- https://access.redhat.com/errata/RHSA-2019:3202
- https://access.redhat.com/errata/RHSA-2019:3203
- https://access.redhat.com/errata/RHSA-2020:0756
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html
- https://github.com/advisories/GHSA-h653-95qw-h2mp
CVE-2019-14858 · published · modified · JSON