PyPI/ansible CVE-2019-10156: unknown, EPSS 1.77%
A flaw was discovered in the way Ansible templating was implemented in versions before 2.6.18, 2.7.12 and 2.8.2, causing the possibility of information disclosure through unexpected variable substitut
Action: Upgrade ansible to 2.6.18 or later.
pip install ansible==2.6.18pip install ansible==2.7.12pip install ansible==2.8.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.6.18 | - |
| 2.7.0 | 2.7.12 | - |
| 2.8.0 | 2.8.2 | - |
Fixed versions
| 2.6.18 | 2.7.12 | 2.8.2 |
Sources
- osv: PYSEC-2019-2
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10156
- https://github.com/ansible/ansible/pull/57188
- https://lists.debian.org/debian-lts-announce/2019/09/msg00016.html
- https://access.redhat.com/errata/RHSA-2019:3744
- https://access.redhat.com/errata/RHSA-2019:3789
- https://lists.debian.org/debian-lts-announce/2021/01/msg00023.html
- https://github.com/advisories/GHSA-grgm-pph5-j5h7
CVE-2019-10156 · published · modified · JSON