PyPI/ansible CVE-2020-1738: unknown, EPSS 0.40%
A flaw was found in Ansible Engine when the module package or service is used and the parameter 'use' is not specified. If a previous task is executed with a malicious user, the module sent can be sel
Action: Upgrade ansible to 2.7.17 or later.
pip install ansible==2.7.17pip install ansible==2.8.9pip install ansible==2.9.6Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.7.17 | - |
| 2.8.0 | 2.8.9 | - |
| 2.9.0 | 2.9.6 | - |
Fixed versions
| 2.7.17 | 2.8.9 | 2.9.6 |
Sources
- osv: PYSEC-2020-10
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1738
- https://github.com/ansible/ansible/issues/67796
- https://security.gentoo.org/glsa/202006-11
- https://github.com/advisories/GHSA-f85h-23mf-2fwh
CVE-2020-1738 · published · modified · JSON