PyPI/scikit-learn CVE-2020-28975: unknown, EPSS 3.50%
** DISPUTED ** svm_predict_values in svm.cpp in Libsvm v324, as used in scikit-learn 0.23.2 and other products, allows attackers to cause a denial of service (segmentation fault) via a crafted model S
Action: Upgrade scikit-learn to 0.24.dev0 or later.
pip install scikit-learn==0.24.dev0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.24.dev0 | - |
Fixed versions
| 0.24.dev0 |
Sources
- osv: PYSEC-2020-108
- https://github.com/scikit-learn/scikit-learn/issues/18891
- https://github.com/cjlin1/libsvm/blob/9a3a9708926dec87d382c43b203f2ca19c2d56a0/svm.cpp#L2501
- http://seclists.org/fulldisclosure/2020/Nov/44
- http://packetstormsecurity.com/files/160281/SciKit-Learn-0.23.2-Denial-Of-Service.html
- https://github.com/advisories/GHSA-jxfp-4rvq-9h9m
CVE-2020-28975 · published · modified · JSON