PyPI/ansible CVE-2020-1740: unknown, EPSS 0.36%
A flaw was found in Ansible Engine when using Ansible Vault for editing encrypted files. When a user executes "ansible-vault edit", another user on the same computer can read the old and new secret, a
Action: Upgrade ansible to 2.7.17 or later.
pip install ansible==2.7.17pip install ansible==2.8.9pip install ansible==2.9.6Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.7.17 | - |
| 2.8.0 | 2.8.9 | - |
| 2.9.0 | 2.9.6 | - |
Fixed versions
| 2.7.17 | 2.8.9 | 2.9.6 |
Sources
- osv: PYSEC-2020-12
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1740
- https://github.com/ansible/ansible/issues/67798
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/DKPA4KC3OJSUFASUYMG66HKJE7ADNGFW/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/WQVOQD4VAIXXTVQAJKTN7NUGTJFE2PCB/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MRRYUU5ZBLPBXCYG6CFP35D64NP2UB2S/
- https://lists.debian.org/debian-lts-announce/2020/05/msg00005.html
- https://security.gentoo.org/glsa/202006-11
- https://github.com/advisories/GHSA-vcg8-98q8-g7mj
CVE-2020-1740 · published · modified · JSON