PyPI/tensorflow CVE-2020-26267: unknown, EPSS 0.24%
In affected versions of TensorFlow the tf.raw_ops.DataFormatVecPermute API does not validate the src_format and dst_format attributes. The code assumes that these two arguments define a permutation of
Action: Upgrade tensorflow to 1.15.5 or later.
pip install tensorflow==1.15.5pip install tensorflow==2.0.4pip install tensorflow==2.1.3pip install tensorflow==2.2.2pip install tensorflow==2.3.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.15.5 | - |
| 2.0.0 | 2.0.4 | - |
| 2.1.0 | 2.1.3 | - |
| 2.2.0 | 2.2.2 | - |
| 2.3.0 | 2.3.2 | - |
Fixed versions
| 1.15.5 | 2.0.4 | 2.1.3 | 2.2.2 | 2.3.2 |
Sources
- osv: PYSEC-2020-140
- https://github.com/tensorflow/tensorflow/commit/ebc70b7a592420d3d2f359e4b1694c236b82c7ae
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-c9f3-9wfr-wgh7
CVE-2020-26267 · published · modified · JSON