PyPI/waitress CVE-2020-5236: unknown, EPSS 2.36%
Waitress version 1.4.2 allows a DOS attack When waitress receives a header that contains invalid characters. When a header like "Bad-header: xxxxxxxxxxxxxxx\x10" is received, it will cause the regular
Action: Upgrade waitress to 1.4.3 or later.
pip install waitress==1.4.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.4.3 | - |
Fixed versions
| 1.4.3 |
Sources
- osv: PYSEC-2020-155
- https://github.com/Pylons/waitress/security/advisories/GHSA-73m2-3pwg-5fgc
- https://github.com/Pylons/waitress/commit/6e46f9e3f014d64dd7d1e258eaf626e39870ee1f
CVE-2020-5236 · published · modified · JSON