PyPI/ansible CVE-2019-14864: unknown, EPSS 1.86%
Ansible, versions 2.9.x before 2.9.1, 2.8.x before 2.8.7 and Ansible versions 2.7.x before 2.7.15, is not respecting the flag no_log set it to True when Sumologic and Splunk callback plugins are used
Action: Upgrade ansible to 2.7.15 or later.
pip install ansible==2.7.15pip install ansible==2.8.7pip install ansible==2.9.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.7.0 | 2.7.15 | - |
| 2.8.0 | 2.8.7 | - |
| 2.9.0 | 2.9.1 | - |
Fixed versions
| 2.7.15 | 2.8.7 | 2.9.1 |
Sources
- osv: PYSEC-2020-160
- https://github.com/ansible/ansible/pull/63527
- https://github.com/ansible/ansible/issues/63522
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14864
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html
- https://github.com/advisories/GHSA-3m93-m4q6-mc6v
CVE-2019-14864 · published · modified · JSON