PyPI/ansible CVE-2014-4657: unknown, EPSS 4.43%
The safe_eval function in Ansible before 1.5.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions.
Action: Upgrade ansible to 1.5.4 or later.
pip install ansible==1.5.4Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.5.4 | - |
Fixed versions
| 1.5.4 |
Sources
- osv: PYSEC-2020-199
- https://www.securityfocus.com/bid/68232
- https://github.com/ansible/ansible/blob/release1.5.5/CHANGELOG.md
- https://github.com/advisories/GHSA-qg47-5px9-32g7
CVE-2014-4657 · published · modified · JSON