PyPI/ansible CVE-2020-10691: unknown, EPSS 0.30%
An archive traversal flaw was found in all ansible-engine versions 2.9.x prior to 2.9.7, when running ansible-galaxy collection install. When extracting a collection .tar.gz file, the directory is cre
Action: Upgrade ansible to 2.9.7 or later.
pip install ansible==2.9.7Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.9.0 | 2.9.7 | - |
Fixed versions
| 2.9.7 |
Sources
- osv: PYSEC-2020-2
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-10691
- https://github.com/ansible/ansible/pull/68596
- https://github.com/advisories/GHSA-3c67-gc48-983w
CVE-2020-10691 · published · modified · JSON