tocsin

PyPI/ansible CVE-2014-4678: critical 9.8, EPSS 5.24%

The safe_eval function in Ansible before 1.6.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions. NOTE: this vulnerability ex

Action: Upgrade ansible to 1.6.4 or later.

pip install ansible==1.6.4

Affected

introducedfixedlast affected
01.6.4-

Fixed versions

1.6.4

Sources

CVE-2014-4678 · published · modified · JSON