PyPI/ansible CVE-2019-14905: unknown, EPSS 0.71%
A vulnerability was found in Ansible Engine versions 2.9.x before 2.9.3, 2.8.x before 2.8.8, 2.7.x before 2.7.16 and earlier, where in Ansible's nxos_file_copy module can be used to copy files to a fl
Action: Upgrade ansible to 2.7.16 or later.
pip install ansible==2.7.16pip install ansible==2.8.8pip install ansible==2.9.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.7.0 | 2.7.16 | - |
| 2.8.0 | 2.8.8 | - |
| 2.9.0 | 2.9.3 | - |
Fixed versions
| 2.7.16 | 2.8.8 | 2.9.3 |
Sources
- osv: PYSEC-2020-206
- https://access.redhat.com/errata/RHSA-2020:0218
- https://access.redhat.com/errata/RHSA-2020:0216
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/5BNCYPQ4BY5QHBCJOAOPANB5FHATW2BR/
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14905
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html
- https://github.com/advisories/GHSA-frxj-5j27-f8rf
CVE-2019-14905 · published · modified · JSON