PyPI/ansible CVE-2020-10684: unknown, EPSS 0.33%
A flaw was found in Ansible Engine, all versions 2.7.x, 2.8.x and 2.9.x prior to 2.7.17, 2.8.9 and 2.9.6 respectively, when using ansible_facts as a subkey of itself and promoting it to a variable whe
Action: Upgrade ansible to 2.7.17 or later.
pip install ansible==2.7.17pip install ansible==2.8.9pip install ansible==2.9.6Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.7.0 | 2.7.17 | - |
| 2.8.0 | 2.8.9 | - |
| 2.9.0 | 2.9.6 | - |
Fixed versions
| 2.7.17 | 2.8.9 | 2.9.6 |
Sources
- osv: PYSEC-2020-207
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-10684
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/DKPA4KC3OJSUFASUYMG66HKJE7ADNGFW/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/WQVOQD4VAIXXTVQAJKTN7NUGTJFE2PCB/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MRRYUU5ZBLPBXCYG6CFP35D64NP2UB2S/
- https://security.gentoo.org/glsa/202006-11
- https://github.com/advisories/GHSA-p62g-jhg6-v3rq
CVE-2020-10684 · published · modified · JSON