PyPI/ansible CVE-2020-10744: unknown, EPSS 0.26%
An incomplete fix was found for the fix of the flaw CVE-2020-1733 ansible: insecure temporary directory when running become_user from become directive. The provided fix is insufficient to prevent the
Action: Upgrade ansible to 2.8.0a1 or later.
pip install ansible==2.8.0a1pip install ansible==2.8.13pip install ansible==2.9.10Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.7.0 | 2.8.0a1 | - |
| 2.8.0 | 2.8.13 | - |
| 2.9.0 | 2.9.10 | - |
Fixed versions
| 2.8.0a1 | 2.8.13 | 2.9.10 |
Sources
- osv: PYSEC-2020-208
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-10744
- https://github.com/advisories/GHSA-vp9j-rghq-8jhh
CVE-2020-10744 · published · modified · JSON