PyPI/tensorflow-gpu CVE-2020-15205: unknown, EPSS 1.03%
In Tensorflow before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, the `data_splits` argument of `tf.raw_ops.StringNGrams` lacks validation. This allows a user to pass values that can cause heap ove
Action: Upgrade tensorflow-gpu to 1.15.4 or later.
pip install tensorflow-gpu==1.15.4pip install tensorflow-gpu==2.0.3pip install tensorflow-gpu==2.1.2pip install tensorflow-gpu==2.2.1pip install tensorflow-gpu==2.3.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.15.4 | - |
| 2.0.0 | 2.0.3 | - |
| 2.1.0 | 2.1.2 | - |
| 2.2.0 | 2.2.1 | - |
| 2.3.0 | 2.3.1 | - |
Fixed versions
| 1.15.4 | 2.0.3 | 2.1.2 | 2.2.1 | 2.3.1 |
Sources
- osv: PYSEC-2020-320
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-g7p5-5759-qv46
- https://github.com/tensorflow/tensorflow/releases/tag/v2.3.1
- https://github.com/tensorflow/tensorflow/commit/0462de5b544ed4731aa2fb23946ac22c01856b80
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00065.html
CVE-2020-15205 · published · modified · JSON