PyPI/ansible CVE-2020-1733: unknown, EPSS 0.40%
A race condition flaw was found in Ansible Engine 2.7.17 and prior, 2.8.9 and prior, 2.9.6 and prior when running a playbook with an unprivileged become user. When Ansible needs to run a module with b
Action: Upgrade ansible to 2.7.17 or later.
pip install ansible==2.7.17pip install ansible==2.8.8pip install ansible==2.9.6Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.7.17 | - |
| 2.8.0 | 2.8.8 | - |
| 2.9.0 | 2.9.6 | - |
Fixed versions
| 2.7.17 | 2.8.8 | 2.9.6 |
Sources
- osv: PYSEC-2020-5
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1733
- https://github.com/ansible/ansible/issues/67791
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/DKPA4KC3OJSUFASUYMG66HKJE7ADNGFW/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/WQVOQD4VAIXXTVQAJKTN7NUGTJFE2PCB/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MRRYUU5ZBLPBXCYG6CFP35D64NP2UB2S/
- https://lists.debian.org/debian-lts-announce/2020/05/msg00005.html
- https://security.gentoo.org/glsa/202006-11
- https://github.com/advisories/GHSA-g4mq-6fp5-qwcf
CVE-2020-1733 · published · modified · JSON