PyPI/py CVE-2020-29651: unknown, EPSS 4.66%
A denial of service via regular expression in the py.path.svnwc component of py (aka python-py) through 1.9.0 could be used by attackers to cause a compute-time denial of service attack by supplying m
Action: Upgrade py to 1.10.0 or later.
pip install py==1.10.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.10.0 | - |
Fixed versions
| 1.10.0 |
Sources
- osv: PYSEC-2020-92
- https://github.com/pytest-dev/py/pull/257/commits/4a9017dc6199d2a564b6e4b0aa39d6d8870e4144
- https://github.com/pytest-dev/py/issues/256
- https://github.com/pytest-dev/py/pull/257
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/AYWNYEV3FGDHPIHX4DDUDMFZ6NLCQRC4/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/CHDTINIBJZ67T3W74QTBIY5LPKAXEOGR/
- https://github.com/advisories/GHSA-hj5v-574p-mj7c
CVE-2020-29651 · published · modified · JSON