PyPI/tensorflow CVE-2021-29591: unknown, EPSS 0.26%
TensorFlow is an end-to-end open source platform for machine learning. TFlite graphs must not have loops between nodes. However, this condition was not checked and an attacker could craft models that
Action: Upgrade tensorflow to 2.1.4 or later.
pip install tensorflow==2.1.4pip install tensorflow==2.2.3pip install tensorflow==2.3.3pip install tensorflow==2.4.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.1.4 | - |
| 2.2.0 | 2.2.3 | - |
| 2.3.0 | 2.3.3 | - |
| 2.4.0 | 2.4.2 | - |
Fixed versions
| 2.1.4 | 2.2.3 | 2.3.3 | 2.4.2 |
Sources
- osv: PYSEC-2021-228
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-cwv3-863g-39vx
- https://github.com/tensorflow/tensorflow/commit/9c1dc920d8ffb4893d6c9d27d1f039607b326743
- https://github.com/tensorflow/tensorflow/commit/c6173f5fe66cdbab74f4f869311fe6aae2ba35f4
CVE-2021-29591 · published · modified · JSON