PyPI/sqlparse CVE-2021-32839: unknown, EPSS 2.34%
sqlparse is a non-validating SQL parser module for Python. In sqlparse versions 0.4.0 and 0.4.1 there is a regular Expression Denial of Service in sqlparse vulnerability. The regular expression may ca
Action: Upgrade sqlparse to 0.4.2 or later.
pip install sqlparse==0.4.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0.4.0 | 0.4.2 | - |
Fixed versions
| 0.4.2 |
Sources
- osv: PYSEC-2021-333
- https://github.com/andialbrecht/sqlparse/commit/8238a9e450ed1524e40cb3a8b0b3c00606903aeb
- https://github.com/andialbrecht/sqlparse/security/advisories/GHSA-p5w8-wqhj-9hhf
CVE-2021-32839 · published · modified · JSON