PyPI/scrapy CVE-2021-41125: unknown, EPSS 1.26%
Scrapy is a high-level web crawling and scraping framework for Python. If you use `HttpAuthMiddleware` (i.e. the `http_user` and `http_pass` spider attributes) for HTTP authentication, all requests wi
Action: Upgrade scrapy to 1.8.1 or later.
pip install scrapy==1.8.1pip install scrapy==2.5.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.8.1 | - |
| 2.0.0 | 2.5.1 | - |
Fixed versions
| 1.8.1 | 2.5.1 |
Sources
- osv: PYSEC-2021-363
- https://github.com/scrapy/scrapy/commit/b01d69a1bf48060daec8f751368622352d8b85a6
- https://w3lib.readthedocs.io/en/latest/w3lib.html#w3lib.http.basic_auth_header
- https://github.com/scrapy/scrapy/security/advisories/GHSA-jwqp-28gf-p498
- http://doc.scrapy.org/en/latest/topics/downloader-middleware.html#module-scrapy.downloadermiddlewares.httpauth
CVE-2021-41125 · published · modified · JSON