tocsin

PyPI/apache-airflow CVE-2021-28359: unknown, EPSS 14.39%

The "origin" parameter passed to some of the endpoints like '/trigger' was vulnerable to XSS exploit. This issue affects Apache Airflow versions <1.10.15 in 1.x series and affects 2.0.0 and 2.0.1 and

Action: Upgrade apache-airflow to 1.10.15 or later.

pip install apache-airflow==1.10.15
pip install apache-airflow==2.0.2

Affected

introducedfixedlast affected
1.8.11.10.15-
2.0.02.0.2-

Fixed versions

1.10.152.0.2

Sources

CVE-2021-28359 · published · modified · JSON